Hostodo - [CONSOLE] Outage – Incident details

[CONSOLE] Outage

Resolved
Major outage
Started 11 days agoLasted 2 days

Affected

Billing / Ordering Portal

Major outage from 11:00 AM to 10:22 PM

Updates
  • Resolved
    UTC
    Resolved

    Hostodo restored the customer panel on clean infrastructure after a 29 August ransomware incident on a control-plane host. Customer VPS disks were NOT the encryption target. Some support tickets after 15 July 2026 were not recoverable; some later invoices may be missing from the panel. We have not found evidence that customer data left our systems; because some logs were altered, we cannot completely rule it out. Additional details will be sent via email.

  • Investigating
    UTC
    Investigating

    We are currently investigating an incident impacting the console, website, and API.